Stax API no longer supports TLS 1.0 and TLS 1.1

Published 11 Sep 2020


Stax is always working to ensure the security of the platform and our customers. As a result, from time to time, changes are introduced to remove insecure or outdated technology. Transport Layer Security (TLS) 1.2 is the industry-agreed recommended minimum cryptographic protocol for HTTP traffic. As a result, SSL and TLS versions older than TLS 1.2 are no longer supported by the Stax API.

From 2020-09-11 the Stax API will require all communication to use TLS 1.2. We maintain support of the following cipher suites: Supported SSL/TLS protocols and ciphers for regional, private, and WebSocket API endpoints in API Gateway.

What does this mean for me?

Ensure any app or integration you've built to use the Stax API supports TLS 1.2. While most applications and programming languages have supported TLS 1.2 for several years, if yours doesn't, you may need to upgrade your application.

If you're using the Stax SDK, you should not need to make any changes. The Stax SDK requires Python 3.6+, which has built in support for TLS 1.2 (as do most modern programming language versions).

If you have any questions regarding this change, please raise a support case with your enquiry.


Back to changelog